X64 Support

Jul 8, 2009 at 3:38 PM

I am trying to use this application in a Server 2008 x64 task sequence and I am getting error 0x8007001f. The log says " A device attached to the system is not functioning" Whatever that means. I tried to run the Exe from the command line and I get " The system cannot execute the specified program"

 

Just curious if x64 winpe is supported?

 

Thanks,

BA

Coordinator
Jul 10, 2009 at 1:46 PM

The application was developed and tested on a 64-bit (Windows 7/Windows Vista) system so x64 is definitely supported. From the error messages above, it looks like you have a bad or inaccessible drive? Are you running the OSDAppChooser.exe before or after formatting the drive? If you are trying to run it before partitioning and the drive has never been formatted before, I think you'll get these messages. 

Jul 10, 2009 at 1:54 PM

Thanks for the reply. I got it to work. I had to put it after the OS image was put down and the configmgr client was installed. Basically I put both actions at the end of my task sequence. Seemed to do the trick.

Thanks,

BA

Dec 8, 2009 at 2:55 PM

I was having the same issue and you are correct that the OSDAppChooser works when you move it down in the TS.  The reason is that the Windows PE x64 does not have any support for WOW64, which is used to run 32-bit apps, but that version of WinPE is required for the toolset to perform modifications to a Windows 7 64-bit OS. 

Once you reboot you are running OSD on top of true Windows 7 with WOW64 support so the OSDAppChooser.exe works.

I like to run OSDAppChooser before I start the system image so my techs can set it and forget it.  Without a 64-bit compile this will be impossible. 

Any chance on getting a 64-bit version?